Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
VST3 plug-in is only seen if Visual Studio is installed
Avatar
Member
Members
August 13, 2021 - 10:31 am
Member Since: April 26, 2021
Forum Posts: 8
sp_UserOfflineSmall Offline

Hi, guys.

I'm using RackAFX for building my plug-ins and it is all working. But if I try to use any of them in another computer, it is not recognized by any DAW (not even VST3PluginTestHost). I'm using Windows 10 64b.

But if I just install Visual Studio on that machine, the plug-ins start to be seen, and they start to work fine. I've tried installing only the vcredist library but that didn't work. Plug-ins only work if I install Visual Studio. 

I'm pretty sure it has to do with some config in VS. Could anyone help me with that?

Thanks!!

Avatar
Member
Members
August 13, 2021 - 5:01 pm
Member Since: June 16, 2021
Forum Posts: 39
sp_UserOfflineSmall Offline

I'm not expert with RACK FX, but are you exporting as an ASPiK project and then building that as a VST?

As far as I know, Rack FX doesn't export/build VST plugins. Only projects to build VSTs. the fact that installing visual studio somehow makes them show up is interesting. What exactly are you doing?

Avatar
Member
Members
August 13, 2021 - 6:47 pm
Member Since: April 26, 2021
Forum Posts: 8
sp_UserOfflineSmall Offline

Thanks for the reply.

I'm doing exactly as instructed in the tutorials, and the plug ins are working as expected - but only if there is Visual Studio installed. And I think it's not a problem with Rackafx. I've just tried using the VST_SDK program generator to build a plug in that does nothing (completely outside RACKAFX or Aspik) - and I've got the same results. The plug in shows up in any computer as long as there is VS installed.

I was blaming VS preferences, but it seems that all extra libraries are used as static . I even made a clean VS reinstall , and got the same results. That's really strange, and frustrating :(.

Avatar
Member
Members
August 17, 2021 - 1:52 pm
Member Since: January 1, 2020
Forum Posts: 53
sp_UserOfflineSmall Offline

Sounds extremely bizarre. I guess you're compiling for Release x64?

I don't see how a VS install could influence the VST3 file in anyways but I don't really know, sorry. More info's could maybe help? What VS version?

Forum Timezone: America/New_York

Most Users Ever Online: 152

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Chaes: 56

jim: 53

Skyler: 48

Derek: 46

Frodson: 45

Peter: 43

TheSmile: 43

clau_ste: 39

Nickolai: 39

JimmyM: 33

Member Stats:

Guest Posters: 1

Members: 732

Moderators: 1

Admins: 5

Forum Stats:

Groups: 13

Forums: 42

Topics: 804

Posts: 3087

Moderators: W Pirkle: 640