Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Problem setting up RackAFX 6.8.2 in Windows 8.1
Avatar
JimmyM
Member
Members
November 12, 2017 - 10:17 pm
Member Since: July 21, 2016
Forum Posts: 33
sp_UserOfflineSmall Offline

Hello Will.

I downloaded and installed the new RackAFX, however when I launch it, occasionally I'll get a quick flash of "RackAFX", but it never starts. I tried re-downloading, installing as admin, reinstalling as admin, etc, however to no avail.

 

I figured I'd check on here to see if I'm missing something. 

 

Hope all is well.

 

JM

Avatar
W Pirkle
Admin
November 13, 2017 - 8:52 am
Member Since: January 28, 2017
Forum Posts: 555
sp_UserOfflineSmall Offline

Is this your first installation ever or are you updating to a new version?

I've had no reports of that happening with a fresh installation. 

If you are updating an existing installation, try moving all the DLLs out of your Plugins Folder (don't delete them, just move them):

C:\Users\<your computer name>\AppData\Roaming\RackAFX\PlugIns

When RackAFX starts it scans and loads plugins from that folder. If a plugin is causing a problem it could prevent RackAFX from starting.

Finally, what OS are you using? We've been using Win8 and Win10 with VS2015 on all our class computers without any issues.

- Will

Avatar
JimmyM
Member
Members
November 13, 2017 - 9:58 pm
Member Since: July 21, 2016
Forum Posts: 33
sp_UserOfflineSmall Offline

Thank you for getting back to me so quickly! I'm using Win 8.1.

 

I did what you suggested, moved all that was in the ...AppData\Roaming\RackAFX\PlugIns and voila! It worked.

 

With the older version I was having trouble with adding elements to tabbed GUIs. The moment I added something, the rendered plugin would show up blank in the host.

 

The only issue I see with the newest version is that the rebuild button doesn't command VS to rebuild - so I have to do that via the VS menu.

 

I'll try a reboot and if it is still an issue, I'll let you know.

 

Thank you again, and for the awesomeness you bring to the VST developer community!

Avatar
W Pirkle
Admin
November 14, 2017 - 12:20 pm
Member Since: January 28, 2017
Forum Posts: 555
sp_UserOfflineSmall Offline

Go to the RackAFX download page and check the section marked "Preparing Visual Studio" - this is just below the download link that you used to download the new version. Follow the link supplied to setup VS for remote rebuilds.

- Will 

Avatar
JimmyM
Member
Members
November 14, 2017 - 9:05 pm
Member Since: July 21, 2016
Forum Posts: 33
sp_UserOfflineSmall Offline

That did it! (Ctrl, Alt, and F7)

 

Thank you very much Will!

Forum Timezone: America/New_York

Most Users Ever Online: 152

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Chaes: 51

Skyler: 48

Derek: 46

Frodson: 45

Peter: 43

TheSmile: 43

clau_ste: 39

jim: 34

JimmyM: 33

Gwen: 32

Member Stats:

Guest Posters: 1

Members: 684

Moderators: 1

Admins: 5

Forum Stats:

Groups: 13

Forums: 41

Topics: 747

Posts: 2853

Newest Members:

duo.dirtykidz, Paul, Reakenzo, jflo, dan_1, phlub, josh, bmarx, Tom Helvey, Ludovic

Moderators: W Pirkle: 555

Administrators: Tom: 74, JD Young: 80, Will Pirkle: 0, W Pirkle: 555, VariableCook: 3