Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Some Errors across OS's and .TYPES
Avatar
Chaes
Member
Members
October 29, 2020 - 7:07 am
Member Since: February 21, 2020
Forum Posts: 51
sp_UserOfflineSmall Offline

Hey guys, 

So I have been experimenting with AU and VST across multiple DAWS and OS's lately and I have come across a strange issue.

When I create a project on Windows, export it, then create and and build a project through CMAKE and XCODE on Mac, the validation for the AU unit fails. 

This is the reasoning :

VERIFYING SPECIAL PROPERTIES:

VERIFYING CUSTOM UI
ERROR: Cocoa Views Information cannot be retrieved

* * FAIL

I am having some other issues, although minor, which ill add later. But I was wondering if this was something specific to having to create it on Mac. A bit like having to use a 32 bit system to compile 32 bit programs, etc.

Has anyone come across this?

Avatar
W Pirkle
Admin
October 29, 2020 - 8:45 am
Member Since: January 29, 2017
Forum Posts: 573
sp_UserOfflineSmall Offline

First, are you creating this project with RackAFX and exporting it, or are you using the ASPiKreator? I am not sure I understand "create a project on Windows and then export it" because that sounds like RackAFX and not ASPiKreator. Next, are you using the latest version of ASPiK? (If you are on RackAFX, then it is always the latest version). I am working on RackAFX right now, and a new ASPiK to release at the same time, and have not had issues with any APIs - in fact, the new VST3 SDK3.7 was simple to add support for - only had to add a few new lines of code.

There is no 32/64 bit issue. All the ASPiK projects, whether RackAFX exported or ASPiKreat-ed, are pure C++ and have no libraries to link with EXCEPT those using FFTW, but you have to supply those libraries. A C++ file made on a 32 bit system is no different than a C++ file created on a 64-bit system. 

Avatar
Chaes
Member
Members
October 30, 2020 - 10:17 am
Member Since: February 21, 2020
Forum Posts: 51
sp_UserOfflineSmall Offline

I have tried both methods. I have created a RackAFX project and exported it as well as using the ASPiKreator to make the project. Both projects were created (and exported for rackafx) in Windows. I run bootcamp so after restarting my macbook back into macOS mode and running cmake and building the xcode project, I get that error in AU.

If I create the project on the macOS side using ASPiKreator and compile, no issues. 

I am using ASPiK 1.6.5; I actually came across this due to trying to figure out why when creating a completely blank project on my mac the AU and VST3 worked on Logic and Ableton but only the AU (and not the VST3) would show up inside FL Studio which I found very very strange! 

Avatar
W Pirkle
Admin
November 3, 2020 - 7:28 am
Member Since: January 29, 2017
Forum Posts: 573
sp_UserOfflineSmall Offline

I will check the Win version for compatibility across the OS line. 

Until then, use the MacOS version of the ASPiKreator for Mac versions.

Forum Timezone: America/New_York

Most Users Ever Online: 152

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Chaes: 51

Skyler: 48

Derek: 46

Frodson: 45

Peter: 43

TheSmile: 43

clau_ste: 39

jim: 34

JimmyM: 33

Gwen: 32

Member Stats:

Guest Posters: 1

Members: 696

Moderators: 1

Admins: 5

Forum Stats:

Groups: 13

Forums: 41

Topics: 757

Posts: 2894

Newest Members:

Jas, Rowan, sojourn, fabhenr, rg1, Niklas, Wutru, Tim Campbell, Danny Jonel, Valentin

Moderators: W Pirkle: 573

Administrators: Tom: 74, JD Young: 80, Will Pirkle: 0, W Pirkle: 573, VariableCook: 3