Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
AU Build error on new ASPiK projects
Avatar
bvaccaro
Member
Members
February 8, 2020 - 2:23 pm
Member Since: February 8, 2020
Forum Posts: 3
sp_UserOfflineSmall Offline

I'm sure this must be a user error issue on my part as it is happening on several systems with varying configurations. I'm hoping someone can point me to the issue. I'm guessing I may have missed a key step in the setup process, but after many attempts, I'm not having any luck finding it.

MacOS 10.14.6

XCode 11.3.1 (I thought this might be the issue, but I've had same problem on other systems with pre-11.3 XCode)

ASPiK 1.6.3

AU SDK as downloaded from this site.

VSTGUI4 4.9

CMake 3.16.2

I'm able to successfully build all samples from the AU v2 samples (as well as the VST3 SDK samples, and the AAX library).

This example is happening with an individual AU API project, but I get same error in a Universal build.

After creating a new project with ASPiKreator, and successfully generating with CMake, the XCode build fails with a Shell Script Invocation Error. I get the following error message while running the CMake PostBuild Rules

Showing Recent Issues
PhaseScriptExecution CMake\ PostBuild\ Rules mac_build/project_source/cmake/au_cmake/Test1a.build/Debug/Test1a.build/Script-CD6AC9637AB64D65A90C6BD2.sh
cd /Users/brandonvaccaro/Documents/Plugin_Devel/ALL_SDK/AU_SDK/myprojects/Test1a
/bin/sh -c /Users/brandonvaccaro/Documents/Plugin_Devel/ALL_SDK/AU_SDK/myprojects/Test1a/mac_build/project_source/cmake/au_cmake/Test1a.build/Debug/Test1a.build/Script-CD6AC9637AB64D65A90C6BD2.sh

/Applications/CMake.app/Contents/bin/cmake -E remove_directory /Users/brandonvaccaro/Documents/Plugin_Devel/ALL_SDK/AU_SDK/myprojects/Test1a/mac_build/AU//Test1a.component/Contents/Resources/Test1a.bundle
/Applications/CMake.app/Contents/bin/cmake -E copy_directory /Users/brandonvaccaro/Documents/Plugin_Devel/ALL_SDK/AU_SDK/myprojects/Test1a/mac_build/AU//Test1a.bundle /Users/brandonvaccaro/Documents/Plugin_Devel/ALL_SDK/AU_SDK/myprojects/Test1a/mac_build/AU//Test1a.component/Contents/Resources/Test1a.bundle
Error copying directory from "/Users/brandonvaccaro/Documents/Plugin_Devel/ALL_SDK/AU_SDK/myprojects/Test1a/mac_build/AU//Test1a.bundle" to "/Users/brandonvaccaro/Documents/Plugin_Devel/ALL_SDK/AU_SDK/myprojects/Test1a/mac_build/AU//Test1a.component/Contents/Resources/Test1a.bundle".
make: *** [Test1a_buildpart_1] Error 1
Command /bin/sh failed with exit code 2

 

Any help would be appreciated. Thanks!

Avatar
W Pirkle
Admin
February 9, 2020 - 1:22 pm
Member Since: January 29, 2017
Forum Posts: 470
sp_UserOfflineSmall Offline

This has just been fixed in v1.6.4 and was an AU-only issue involving the Cocoa GUI target. 

It was actually traced back to a line of code in the CMake script which also affected the GUI. 

Standby for the new version that fixes this. It will require re-creating the project and re-running Cmake. If you already have worked on your plugin and have controls and code in your plugincore.h and plugincore.cpp files, then you can stash those away, create the new (fixed) version, and then copy these files back over to get your controls back. 

Will

Avatar
W Pirkle
Admin
February 9, 2020 - 2:01 pm
Member Since: January 29, 2017
Forum Posts: 470
sp_UserOfflineSmall Offline

This has now been fixed in the latest v1.6.4 release. 

Will 

Avatar
bvaccaro
Member
Members
February 9, 2020 - 6:05 pm
Member Since: February 8, 2020
Forum Posts: 3
sp_UserOfflineSmall Offline

Thanks for the quick response and update.

I'm having trouble loading the 1.6.4 ASPiKreator on the same system. I get an error message from MacOS: "ASPiKreator" is damaged and can't be opened. You should move it to the Trash. Same issue with both the SDK and the direct ASPiKreator download.

Thanks again!

Avatar
W Pirkle
Admin
February 10, 2020 - 5:44 pm
Member Since: January 29, 2017
Forum Posts: 470
sp_UserOfflineSmall Offline

Hmm. The ASPiKreator should work for OS 10.10 and up. Let me try a new compile. Sorry about that.

Will 

Avatar
W Pirkle
Admin
February 11, 2020 - 11:04 am
Member Since: January 29, 2017
Forum Posts: 470
sp_UserOfflineSmall Offline

OK I have a couple of variations here for you to try - LMK what happens.

There are two versions in this zip, in two folders one compiled for 10.10 and up and the other for 10.12 and up.

http://willpirkle.com/Download.....eators.zip

- Will 

Avatar
bvaccaro
Member
Members
February 11, 2020 - 9:47 pm
Member Since: February 8, 2020
Forum Posts: 3
sp_UserOfflineSmall Offline

Hey Will - Worked like a charm this time. Thanks again!

Avatar
W Pirkle
Admin
February 24, 2020 - 2:50 pm
Member Since: January 29, 2017
Forum Posts: 470
sp_UserOfflineSmall Offline

OK - well the culprit had something to do with the fact that the ASPiKreator contains a .zip block file deep inside of it. The act of zipping and uploading the file caused an issue. Downloading and unzipping the file produced the "damaged" error and I was able to do this on my own system, back to back. 

I have modified the ASPiKreator bundle and there is a new version that is working after downloading now. Thanks for the report.

https://www.aspikplugins.com/download/

Will

Forum Timezone: America/New_York

Most Users Ever Online: 152

Currently Online:
10 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Skyler: 48

Derek: 46

Frodson: 45

Peter: 43

TheSmile: 43

clau_ste: 39

Chaes: 37

JimmyM: 33

Gwen: 32

jim: 27

Member Stats:

Guest Posters: 1

Members: 648

Moderators: 1

Admins: 4

Forum Stats:

Groups: 13

Forums: 40

Topics: 695

Posts: 2674

Newest Members:

oneday, Phelan Kane, audiocoder, agel, Makai, Abyz, Nonlinear, IgorVish, Arjuna, TomMilne

Moderators: W Pirkle: 470

Administrators: Tom: 74, JD Young: 80, Will Pirkle: 0, W Pirkle: 470