Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
SMTG_PLUGIN_TARGET_PATH, Could NOT find EXPAT (missing: EXPAT_LIBRARY EXPAT_INCLUDE_DIR)
Avatar
djd_oz
New Member
Members
June 10, 2020 - 3:25 am
Member Since: June 10, 2020
Forum Posts: 2
sp_UserOfflineSmall Offline

Hey there,

I'm just following the instructions to compile the VST3 SDK default plugins following this video, https://www.youtube.com/watch?time_continue=146&v=004zcWwgi1A&feature=emb_logo and am getting the below errors. I'm using Windows10, Visual Studio 2019. I've installed cMake and also Expat and ran the below commands.

mkdir build

cd build

 

C:\Users\djd_o\Plugin_SDK\VST_SDK\VST3_SDK\build>cmake -G"Visual Studio 16 2019" ../
CMake Error at cmake/modules/AddVST3Options.cmake:31 (file):
file problem creating directory: C:/Program Files/Common Files/VST3
Call Stack (most recent call first):
cmake/modules/SMTG_VST3_SDK.cmake:13 (include)
CMakeLists.txt:10 (include)

-- SMTG_PLUGIN_TARGET_PATH is not set!
-- SMTG_MYPLUGINS_SRC_PATH is set to : C:/Users/djd_o/Plugin_SDK/VST_SDK/VST3_SDK/../my_plugins
-- SMTG_PACKAGE_ICON_PATH is set to : C:/Users/djd_o/Plugin_SDK/VST_SDK/VST3_SDK/doc/artwork/VST_Logo_Steinberg.ico
-- Selecting Windows SDK version 10.0.18362.0 to target Windows 10.0.18363.
-- Could NOT find EXPAT (missing: EXPAT_LIBRARY EXPAT_INCLUDE_DIR)
-- VSTGUI will use the embedded Expat package!
-- VSTGUI_ROOT is set to : C:/Users/djd_o/Plugin_SDK/VST_SDK/VST3_SDK
-- SMTG_AAX_SDK_PATH is not set. If you need it, please download the AAX SDK!
-- Configuring incomplete, errors occurred!
See also "C:/Users/djd_o/Plugin_SDK/VST_SDK/VST3_SDK/build/CMakeFiles/CMakeOutput.log".

C:\Users\djd_o\Plugin_SDK\VST_SDK\VST3_SDK\build>

Avatar
djd_oz
New Member
Members
June 10, 2020 - 6:04 am
Member Since: June 10, 2020
Forum Posts: 2
sp_UserOfflineSmall Offline

I've solved it. I just created the directory C:/Program Files/Common Files/VST3 manually.

Forum Timezone: America/New_York

Most Users Ever Online: 152

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Skyler: 48

Derek: 46

Frodson: 45

Peter: 43

TheSmile: 43

clau_ste: 39

JimmyM: 33

Gwen: 32

EZB: 24

lppier: 23

Member Stats:

Guest Posters: 1

Members: 632

Moderators: 1

Admins: 4

Forum Stats:

Groups: 13

Forums: 40

Topics: 667

Posts: 2597

Newest Members:

VariableCook, Henry, Adekoya Adams, WillAMR, weedshop, Gennaro Schiano, HOA, sanketVxT, sem1307, djd_oz

Moderators: W Pirkle: 462

Administrators: Tom: 74, JD Young: 80, Will Pirkle: 0, W Pirkle: 462