CMake Error Unknown CMake command "smtg_get_default_vst3_path" | Compiler Errors & Warnings | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
CMake Error Unknown CMake command "smtg_get_default_vst3_path"
Avatar
Member
Members
March 31, 2020 - 3:17 am
Member Since: March 31, 2020
Forum Posts: 5
sp_UserOfflineSmall Offline

Hi,

    Will,

            I am new to RackAFX last couple of days I was trying your framework RACKAFX by following your videos on Youtube. I had done all the steps guided by you. RACKAFX 7 portion is OK. I had exported ASPIK project also but when I'm trying to generate the solution file to build VST3, Cmake ends up with the error.

CMake Error at cmake/vst_cmake/CMakeLists.txt:87 (smtg_get_default_vst3_path):
Unknown CMake command "smtg_get_default_vst3_path".

I have downloaded VST_SDK (vst-sdk_3.6.14_build-24_2019-11-29) from Steinberg site (no GitHub stuff.)

My path are exactly similar what you have shown on your videos

C:\VST_SDK\VST3_SDK\myprojects  (I have also attached vstgui4 directory over here)

C:\VST_SDK\VST3_SDK\myprojects\VOLUMAX  (generated ASPik project)

C:\VST_SDK\VST3_SDK\myprojects\VOLUMAX\win_build>  (This is my address CMD propmt)

Camke Command i am using is     cmake -G"Visual Studio 14 2015 Win64" ../

What I am doing wrong?

I had contacted you via Youtube but no response. Hope you are well in the COVID-19 situation.

Please help me to build VST3 files. I want to learn more about RackAFX and please make it simple. Your previous version was very simple to build VST.dll and .vst3(but not working in new Windows 7 build ver 1909)  new ASPIK & CMake stuffs are (ufffCry) very confusing and hard to compile. Please Make it available from RACKAFX. It will be easier to generate VST,AU,AAX from RackAFX only.

Avatar
Member
Members
March 31, 2020 - 10:29 am
Member Since: February 25, 2020
Forum Posts: 9
sp_UserOfflineSmall Offline

Hi Tania.  Myself and others are having the same problem.  See this forum topic:

https://www.willpirkle.com/forum/compiler-errors-warnings/exported-vst-on-win64/

It appears that the Export to ASPIK function in the latest version is broken.  We are waiting for a fix.

 

Al

Avatar
Admin
April 6, 2020 - 5:26 pm
Member Since: January 29, 2017
Forum Posts: 689
sp_UserOfflineSmall Offline

HI everyone - 

I have a new rev ready and I have tested the VST export. The culprit was a CMakeLists.txt file of script (what puzzled me was that in the ASPiK SDK, it is all correct).

I have added a newer feature to allow you to copy and move controls more easily on the main GUI and it is the start of several prototyping helpers (e.g. shift a row of knobs down). 

Once that is tested then I will do the new release - there won't be an ASPiK release because it is fundamentally OK (I have a short TODO list, but don't want to hold this up any longer).

I will try to get the new release done tomorrow night or Wednesday morning. I am sorry for the inconvenience but have been dealing with moving all my classes online and trying to finish the semester, do graduate thesis defenses, and graduate the seniors (grade senior projects and presentations) all from home. The good news is that my ability to offer online classes or seminars has just been upgraded to READY.

I will let you know when I upload 7.0.1.6 and will probably also do a short video on moving and copying prototyping controls.

Will 

Avatar
Admin
April 8, 2020 - 3:07 pm
Member Since: January 29, 2017
Forum Posts: 689
sp_UserOfflineSmall Offline

Please upgrade to the new version 7.0.1.7 which fixes the ASPiK export for VST3 plugins. This version also adds a new feature involving the prototyping panel; I will post a video shortly.

Will

Avatar
Member
Members
April 8, 2020 - 5:13 pm
Member Since: February 25, 2020
Forum Posts: 9
sp_UserOfflineSmall Offline

Thank you Will.  The new version worked perfectly.  I am now making VST plugins that work in my DAW.

Forum Timezone: America/New_York

Most Users Ever Online: 152

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Chaes: 56

Skyler: 48

StevieD: 46

Derek: 46

Frodson: 45

Peter: 43

TheSmile: 43

Nickolai: 43

clau_ste: 39

jeanlecode: 37

Member Stats:

Guest Posters: 1

Members: 768

Moderators: 1

Admins: 6

Forum Stats:

Groups: 13

Forums: 42

Topics: 842

Posts: 3347

Moderators: W Pirkle: 689