Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
RAFX deleting/changing code when clicking "rebuild"
No permission to create posts
May 26, 2016
7:07 pm
Avatar
Holy_City
Member
Members
Forum Posts: 5
Member Since:
May 26, 2016
sp_UserOfflineSmall Offline

Hey Will/any other users who have run into this issue

I'm using VS Community 2015 (win7), and I ran into an issue where using the "rebuild" button within RAFX will delete any changes made in the plugin .h/.cpp files back to a certain state of those files from a day ago. Building within VS works fine.

May 29, 2016
9:23 pm
Avatar
W Pirkle
Admin
Forum Posts: 143
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

I have not observed this (using VS2015 Community) - when you hit the Rebuild button, RAFX first sends a "Save All" command to Visual Studio to prevent this very thing from happening. It uses keystrokes to do this, so check your Save All keystroke settings in VS (should be S).

- Will

June 1, 2016
8:43 pm
Avatar
Holy_City
Member
Members
Forum Posts: 5
Member Since:
May 26, 2016
sp_UserOfflineSmall Offline

I reset the keyboard shortcuts to default (Cntrl+shift+s for save all) and RAFX is still deleting changes, but it's reserved to the plugin's .h file. I think this issue popped up after I set VS to not prompt for rebuild when I click "debug" in RAFX if that helps.

June 1, 2016
8:46 pm
Avatar
Holy_City
Member
Members
Forum Posts: 5
Member Since:
May 26, 2016
sp_UserOfflineSmall Offline

I found a workaround, just adding/removing a dummy control in RAFX fixed it.

June 1, 2016
11:14 pm
Avatar
W Pirkle
Admin
Forum Posts: 143
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

Did your original project have no GUI controls at all, so you were just operating in processAudioFrame(), or were there existing controls already?

- Will

June 2, 2016
6:50 pm
Avatar
Holy_City
Member
Members
Forum Posts: 5
Member Since:
May 26, 2016
sp_UserOfflineSmall Offline

I had controls already

June 2, 2016
8:54 pm
Avatar
W Pirkle
Admin
Forum Posts: 143
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

OK, if this ever happens again, please do me a favor and save/zip the entire project folder, then use the Contact form to email me a dropbox link to that so I can replicate (you can delete any signal processing code you don't want me to see - I don't care about that stuff). It appears that somehow the RAFX project file (.prj) became out of sync with the Visual Studio project file.

Also, for the record you can force a re-sync by using Plugin -> Synchronize Code or the toolbar button that looks like double arrows.

Will

Forum Timezone: America/New_York

Most Users Ever Online: 36

Currently Online:
7 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Skyler: 47

Peter: 41

Derek: 41

clau_ste: 39

Frodson: 38

Gwen: 32

EZB: 24

lppier: 23

Msaldaña: 18

Jorge: 17

Member Stats:

Guest Posters: 1

Members: 476

Moderators: 1

Admins: 4

Forum Stats:

Groups: 11

Forums: 30

Topics: 482

Posts: 1876

Newest Members:

sam, annaharris, Marie Weaver, kev, Steven, Mr Anderson, mguy, omelc

Moderators: W Pirkle: 143

Administrators: Tom: 65, JD Young: 80, Will Pirkle: 0, W Pirkle: 143