Please consider registering

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
CWTOscillator does not create wavetables in chapter 5 "Synthesizer Oscillator Design"
No permission to create posts
February 8, 2015
2:47 am
Forum Posts: 8
Member Since:
January 10, 2015
sp_UserOfflineSmall Offline

In chapter 5, the base Oscillator class initializes the samplerate to 44100 in the constructor, so when the CWTOscillator object receives setSampleRate, the check for a different samplerate fails and the wavetables do never get created. Either there should a boolean be added to specify if initialized or a check on the actual wavetables must be performed in the setSamplerate's conditional. I chose the second option.

Ha, the CWTOscillators sound great ;)


Forum Timezone: America/New_York

Most Users Ever Online: 36

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Skyler: 48

Derek: 41

Peter: 41

Frodson: 40

clau_ste: 39

Gwen: 32

EZB: 24

lppier: 23

Msaldaña: 18

Jorge: 17

Member Stats:

Guest Posters: 1

Members: 495

Moderators: 1

Admins: 4

Forum Stats:

Groups: 11

Forums: 31

Topics: 511

Posts: 1966

Newest Members:

CoraDias, Edoardo, knooierd, daniel, Merril Bradshaw, BillPlunkett, Pajczur, michaelwayneharwood, RickM, rainbow wind

Moderators: W Pirkle: 187

Administrators: Tom: 66, JD Young: 80, Will Pirkle: 0, W Pirkle: 187