Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
CreateProcess() Error
No permission to create posts
December 29, 2018
3:37 pm
Avatar
Cal
New Member
Members
Forum Posts: 2
Member Since:
December 29, 2018
sp_UserOfflineSmall Offline

 I am trying to follow the example for the volume plugin. When I try to create a new project, I get an error -

"Error in CreateProcess() for the compiler path: path to compiler not found in registry"

It says to check compiler choice in View -> properties (Maybe I am missing something here?)

I am Vs 2017 installed on my PC and I am running as the admin on windows 7

 

Thank you

December 29, 2018
4:20 pm
Avatar
W Pirkle
Admin
Forum Posts: 261
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

In VS2017, Microsoft changed a paradigm that had existed for 20 years, where they wrote the path to the compiler's EXE in the system registry; they stopped writing that information which RackAFX used to find the EXE to launch via CreateProcess( ).

In RackAFX when you choose VS2017 in View -> Preferences, it should pop up a message asking you to browse and locate the EXE (named devenv.exe) so it can store that for future use. Did you set the compiler in View -> Preferences?

If you did, then you should have gotten that message box to find the EXE. If you did not get that message, change the compiler back to VS2015 and hit OK (close all projects before doing that). Then, go back to View -> Preferences and choose VS 2017; it will ask you to find the EXE either right then, or when you try to exit the dialog with OK. Let me know if you did set the VS2017 compiler but did not get the message to find the EXE as no one has reported that (and I've not experienced it either). 

The location of the devenv.exe may be different on different OS's so you have to find it manually as I can't second guess that information. It may be located at:

C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\devenv.exe

Note that there is a known Microsoft bug with VS2017 and projects designed with previous versions (it is documented on the download page where you got RackAFX, after the release notes - not a big deal, but you will have to manually select the correct toolkit). I reported this to Microsoft, and they acknowledged it, but they have not fixed it yet. 

http://www.willpirkle.com/rack.....downloads/

Other notes: I will not be officially supporting Win7 in future versions of RackAFX, though it may very well be possible to run and use it without problems. In addition, users have reported all kinds of issues with using VS2017 on OS's earlier than Win 8.0 (8.1 and later are OK) and the latest VST3 SDK, so if you plan on building VSTs, then you will have to address that at some point. 

- Will 

January 11, 2019
1:07 pm
Avatar
Cal
New Member
Members
Forum Posts: 2
Member Since:
December 29, 2018
sp_UserOfflineSmall Offline

Thank you, that solved that issue. I have come across another problem with the volume file. It seems that the slider is not working within rackAFX. Its moving but it is not affecting the volume as I am playing through it. Would this possibly have something to with routing? I have loaded the plugin within rackAFX

Forum Timezone: America/New_York

Most Users Ever Online: 55

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Skyler: 48

Derek: 46

Frodson: 43

Peter: 41

clau_ste: 39

Gwen: 32

JimmyM: 30

TheSmile: 28

EZB: 24

lppier: 23

Member Stats:

Guest Posters: 1

Members: 527

Moderators: 1

Admins: 4

Forum Stats:

Groups: 11

Forums: 31

Topics: 552

Posts: 2168

Newest Members:

Steve Duell, Cal, LamebrainEddy, SteveThackery, rawbirdtoe, Bill, hill william, NAUN_SONAR, sufy, Diane

Moderators: W Pirkle: 261

Administrators: Tom: 67, JD Young: 80, Will Pirkle: 0, W Pirkle: 261