Please consider registering

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
VS-Error 'can not read *.vxproj'
No permission to create posts
February 1, 2016
12:07 am
Forum Posts: 6
Member Since:
January 30, 2016
sp_UserOfflineSmall Offline


I use VS-2013 (first VS-2015, but it does not work, so I have installed VS-2013 too), Windows 8.1 (64 bit).

When I load a project in RackAFX or create a new one, I get an error from VS:
'can not read *.vxproj... invalid sign at x,y... can not load.'

I close the project in VS & edit the *.vxproj via NotePad++ and find at x,y:

the sign 'ü' (UFT-8: xFC).

Unfortunately my UserName contains this sign.

In the '*.vcproj' I find these entries:

AdditionalDependencies="Sock2VST3d.lib base_vc9d.lib .
esources\Sock2VST3.res "

So I create another RackAFX path & choose it in RackAFX via 'View-Preferences': D:\JO\MU\RackAFX.
But the same result: the same old entries!
Even I delete chache-files in 'C:\Users\UserName\AppData\Local\Microsoft\VisualStudio'.
It seems that RackAFX expects the plugin-DLL allways in the folder C:\Users\UserName\AppData\Roaming\RackAFX\PlugIns.

My workaround:
I edit both files '*.vcxproj' & '*.vcproj' after I get the error message.
I make changes in '*.vcxproj':
C:\Users\UserName\AppData\Roaming -> D:\JO\MU\RackAFX

I make changes in '*.vcproj':
C:\Users\willpirkle\AppData\Roaming -> D:\JO\MU\RackAFX
Sock2VST3d.lib base_vc9d.lib -> Sock2VST3d_vc12.lib base_vc12d.lib

Now I can add code, controls via RackAFX & can rebuild the plugin.
The plugin works fine in Cubase!

I like to create all the plugins in the books 'Software Synthesizer Plug-Ins' & 'Audio Effect Plug-Ins'.
But I think I have overlooked something, there must be an easier way to do this like I do.


February 2, 2016
7:21 pm
W Pirkle
Forum Posts: 187
Member Since:
January 29, 2017
sp_UserOfflineSmall Offline

This issue turned out to be a problem with the user's User Name, which included an umlaut symbol - thus his AppData path contained a character that Visual Studio 2010/2012/2013/2015 could not recognize.

I have addressed this in the next update of RackAFX and have notified the user how to fix the issue. If anyone has similar problems, just contact me and I will explain the simple fix. Note that this is an issue with using a non-ASCII character in your User Name when you setup your Windows OS, so it is unlikely to affect many other people.


Forum Timezone: America/New_York

Most Users Ever Online: 36

Currently Online:
3 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Skyler: 48

Derek: 41

Peter: 41

Frodson: 40

clau_ste: 39

Gwen: 32

EZB: 24

lppier: 23

Msaldaña: 18

Jorge: 17

Member Stats:

Guest Posters: 1

Members: 495

Moderators: 1

Admins: 4

Forum Stats:

Groups: 11

Forums: 31

Topics: 511

Posts: 1966

Newest Members:

CoraDias, Edoardo, knooierd, daniel, Merril Bradshaw, BillPlunkett, Pajczur, michaelwayneharwood, RickM, rainbow wind

Moderators: W Pirkle: 187

Administrators: Tom: 66, JD Young: 80, Will Pirkle: 0, W Pirkle: 187