Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Problems with Version 6.7.0.2 and "cannot open Synth.dll for writing"
No permission to create posts
March 23, 2016
3:41 pm
Avatar
Werner
Member
Members
Forum Posts: 3
Member Since:
March 23, 2016
sp_UserOfflineSmall Offline

Hi Will,

Thank you for your two books, for RackAfx and for your web site. These are all great resources. Very good explained and very helpful to get started. Thank you very much!

I downloaded 6.7.0.2 it looks promissingCool.

I’m on Mac/Parallels , Win10, VS2013 Community and I encountered two problems:

1) after RackAfx converted a project, VS2013 will never load it.
I have to delete the first 2 Lines in synth.vcxproj and the first 3 signs of the third line:

ï *.cdf;*.cache;*.obj;*.ilk;*.resources;*.tlb;*.tli;*.tlh;*.tmp;*.rsp;*.pgc;*.pgd;*.meta;*.tlog;*.manifest;*.pch;*.exp;*.idb;*.rep;*.xdc;*_manifest.rc;*.bsc;*.sbr;*.xml

ï *.cdf;*.cache;*.obj;*.ilk;*.resources;*.tlb;*.tli;*.tlh;*.tmp;*.rsp;*.pgc;*.pgd;*.meta;*.tlog;*.manifest;*.pch;*.exp;*.idb;*.rep;*.xdc;*_manifest.rc;*.bsc;*.sbr;*.xml



2) I have audio glitches in 6.7.0.2. The same project with the same latency and the same audio buffer settings plays in 6.6.4.1 without glitches. Changing the settings does not help.
(MME or WASAPI, Parallels Audio Controller). When using Asio4All RackAfx 6.7.0.2 says Pa_OpenStream failed. Asio4All works in 6.6.4.1

3) Another problem I can’t find a solution for is that I have to close RackAfx to compile again (in both RackAfx version 6.6 and 6.7). It seems that RackAfx does not release the synth.dll, so VS2013 complains:
Error 4 error LNK1168: cannot open Synth.dll for writing
This happened the first time after having a crash of RackAfx in Debug-Mode

Any help appriciated
Werner

March 23, 2016
5:00 pm
Avatar
W Pirkle
Admin
Forum Posts: 143
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

6.7.0.2 is in private Beta right now. I did not change the beta password so you should not be using it yet. That said...

You may want to uninstall it and go back to the release version. Or use the Contact form and I will add you to the beta tester list and would need to see your synth project to address issues.

You can use View -> RackAFX GUI Mode -> Classic View to go back to the original GUI. If that alleviates your issues then you know it is the GUI causing any glitches. But I doubt the GUI is the problem.

1) this has been fixed in the current development version when converting synth-book derivative projects (another reason you should not be using the beta version unless you are in the test group).

2) ASIO4ALL has never worked properly for me in any version of RackAFX, Reaper, Pro Tools, etc... so I don't have a good baseline to test against. However, it does open properly and I do not give a Port Audio error in RackAFX (but it is glitchy, just like it is in ProTools, which leads me to think it is a Parallels/driver issue).

I am currently using a Presonus AudioBox 44VSL without any issues in the beta version. However, I have had numerous issues with other drivers, including Microsoft Sound Mapper and Parallels - I will typically need to reboot my Mac and restart Parallels to get glitch-free audio. The change in v6.7.x regarding audio setup is that you can now use Line In as the Sidechain input (a request I've gotten a lot) and that requires me to always place your audio driver in full-duplex mode meaning that I have to setup the port audio system for an input and output simultaneously (note that this also occurs when you use Line In mode (aka Sample Soundcard Input). Again, my Audiobox never has issues with this.

3) this error is usually due to a bug in the plugin, specifically something not being released in the Destructor which is causing the DLL to stay loaded after the call to free it. Unfortunately, the FreeLibrary( ) function returns SUCCESS for many failures, meaning that RackAFX can't issue you a warning because the function is stating that the DLL unloaded properly.

I will change the password to the beta site for now; if you want to join the beta test group use the contact form. Please use email correspondence for any Beta test related questions or concerns.

- Will

March 24, 2016
2:48 am
Avatar
W Pirkle
Admin
Forum Posts: 143
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

Also, I have not seen a difference in processing/glitching between 6.6 and 6.7 so please use the Contact form and we can discuss via email.

Will

March 30, 2016
6:47 pm
Avatar
Werner
Member
Members
Forum Posts: 3
Member Since:
March 23, 2016
sp_UserOfflineSmall Offline

Hi Will,

thank you very much for the super fast updates.
In the actual 6.7 version there are no more glitches and Asio works fine.Cool

Werner

March 31, 2016
6:24 pm
Avatar
W Pirkle
Admin
Forum Posts: 143
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

HI Werner

You mentioned that you used ASIO4ALL and I am wondering if there are any settings within its ASIO control panel that work best with RackAFX? One of my students (and I) have issues with ASIO4ALL creating garbled audio in Parallels/Virtual Box and Win8.1 64-bit. ASIO4ALL won't work with any of my other clients either so I am wondering if there is anything else that needs to be changed in the ASIO control panel. I am also on Parallels.

Thanks

Will

March 31, 2016
7:26 pm
Avatar
Werner
Member
Members
Forum Posts: 3
Member Since:
March 23, 2016
sp_UserOfflineSmall Offline

Hi Will,

I am on Win10 maybe this is the difference?
Mac El Capitan -> Parallels11 -> Win10 -> Asio4All 2.13 Settings Buffersize 256 Samples -> it goes into Parallels Audio Controller. On the Mac side my Audio Interface is connected via USB and Focusrite Asio driver.
There are some more options in Asio4All but I clicked none of them.

When loading the Synth.dll in RackAfx there is one click in the begnning. But then it works without any problems. Of course Parallels adds a bigger delay then 256 Samples but with Asio4All here on my system this is the smallest latency I can get. (Or does anybody know a way to adjust latency in Parallels?)

When I connect the Audio Interface on the Parallels side to Win10 and then select Focusrite Asio in RackAfx this does not work stable.

Werner

May 6, 2016
3:37 pm
Avatar
rkln
New Member
Members
Forum Posts: 1
Member Since:
May 6, 2016
sp_UserOfflineSmall Offline

Will said

HI Werner

You mentioned that you used ASIO4ALL and I am wondering if there are any settings within its ASIO control panel that work best with RackAFX? One of my students (and I) have issues with ASIO4ALL creating garbled audio in Parallels/Virtual Box and Win8.1 64-bit. ASIO4ALL won't work with any of my other clients either so I am wondering if there is anything else that needs to be changed in the ASIO control panel. I am also on Parallels.

Thanks

Will

Hi Will, I want to test the version 6.7. How do I do?

May 6, 2016
3:55 pm
Avatar
W Pirkle
Admin
Forum Posts: 143
Member Since:
January 28, 2017
sp_UserOfflineSmall Offline

Use the Contact form to email me and I will give you the information.

- Will

Forum Timezone: America/New_York

Most Users Ever Online: 36

Currently Online:
2 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Skyler: 47

Peter: 41

Derek: 41

clau_ste: 39

Frodson: 38

Gwen: 32

EZB: 24

lppier: 23

Msaldaña: 18

Jorge: 17

Member Stats:

Guest Posters: 1

Members: 476

Moderators: 1

Admins: 4

Forum Stats:

Groups: 11

Forums: 30

Topics: 482

Posts: 1876

Newest Members:

sam, annaharris, Marie Weaver, kev, Steven, Mr Anderson, mguy, omelc

Moderators: W Pirkle: 143

Administrators: Tom: 65, JD Young: 80, Will Pirkle: 0, W Pirkle: 143